Google Calendar Time Zone is out

Hi Guys, I have my google calendars coming through to my klip fine, the only problem I currently have is that the time is 2 hours less than the event in my google calendar.

My test event is set from 12:00 to 13:00 (1hour) and I'm getting 10:00 till 11:00 in my klip data.



Google Calendar  

I've made sure my google calendar is set to UTC

And within Klipfolio my time zone is set to GMT +2 (South Africa).

My query I'm running:

And my sorting of times and dates is from the standard Klipfolio Klip for Google Calendar.

I don't know how to change the time to be the same as my google calendar info or even just to Add 2H to times (as I last resort)



  • 0
    Janice Janczyn

    Hi Machiel,

    Does the time in your Google Calendar datasource (in Klipfolio) match your Google calendar or is it 2 hours behind?  We may need to take a closer look to understand what is happening--please send an email to support@klipfolio.com and enable support access so we can sign into your account.

    Thank you,

  • 1
    Machiel Odendaal


    Solution to the problem I've found was:

    What I've done:
    1. I've put my time zone within Klipfolio to the default GMT (Overall Settings

    2. Within the Klip, under the Properties tab. Put the:
    - Format as: Automatically set format
    - Input Format: Left as is.
    - Display Format: Change to the REQUIRED TIME ZONE, which is the GMT +2:00.

    That seemed to work and changed the times as how Google Calendar is showing the times to me (correct time zone).

Please sign in to leave a comment.